[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] Inconsistent networking between Xen & QEMU



On Fri, Mar 09, 2007 at 02:27:02PM +0000, Mark McLoughlin wrote:
> On Fri, 2007-03-09 at 03:03 +0000, Daniel P. Berrange wrote:
> 
> > Anyway, we now have two different syntaxes in the XML for defining what
> > is more or less the same thing which is a real PITA for the tools. It
> > is useful to have the distinct representations - one is for 'managed'
> > bridges, and the other is for 'unmanaged' bridges - we can do some much
> > more interesting things with managed bridges.  
> 
> 	As I said in another mail, the way I'd imagined virt-install working
> would be that by default it would connect guest NICs to the default
> network (i.e. not the bridge associated with the default network), but
> you could still use --bridge to explicitly connect the guest to a
> bridge. And we'd have a --network option.

I think we need to explore this a little further - the APIs for virtual
networks are very nice froma tools POV because we can trivially enumerate
networks & connect VMs to them. Its not pleasent to have to enumerate the
regular non-virtual network devices using a different set of APIs - indeed
its impossible if we're talking to a remote libvirt. So I think we need to
look at also exposing the 'shared physical device' style networks via the
libvirt APIs too. 

This could be expressed with something like:

<network>
  <name>default</name>
  <bridge name="virbr0" />
  <device name="eth0" />
</network>

Which would setup a virbr0 bridge,and enslave eth0 to it. It would assume
that the network eth0 is connected to has DHCP already, so there's no need
to define an IP for the bridge itself, or run dnsmasq in this case.

Is it actually possible to take an already configured eth0 device and
enslave it to virbr0 without eth0 loosing its address config/routes ?

If we have this kind of support could we auto-generate network configs at
runtime based on any bridge/network device the adminsitrator has already
manually configured via /etc/sysconfig/networking-scripts ?

Dan.
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]