[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvir] libvirt not compatible with Xen-unstable hypercall API ?



While trying to verify any potential problem between with libvirt & Xen
PPC port. I've found that libvirt currently in CVS attempts to determine
what hypercall version to follow, by looking at the hypervisior version.
It determines that this is some arbitrary versioning "v2" of the
hypercall api. This starts on line 1250 of xen_internal.c. This does not
appear to be compatible with current Xen-Unstable from testing and
trying to hack it up.

Has any work been done toward making libvirt compatible with
Xen-unstable that has not been included? Or is it waiting till the
offical 3.0.5 release? 

We are attempting to ensure that Xen PPC works with libvirt. Though we
have to use the latest hypercall api. 

		Thanks,
			Jerone 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]