[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] The fist problem to compile libvirt in a Debian etch.



On Mon, May 07, 2007 at 11:24:12AM -0300, Marco Sinhoreli wrote:
> Attached the commands result for CFLAGS="-fno-stack-protector" ./configure
> 2>&1 | tee configure.log and make 2>&1 | tee make.log.
> 
> Is possible run the make only if I comment the libxml test in configure
> script.
> 
> regards
> 
> 
> 
> On 5/7/07, Marco Sinhoreli <msinhore gmail com> wrote:
> >
> >Hello guys,
> >
> >To finish the libvirt compilation, I've commented:
> >
> >file: libvirt/configure:
> >#elif test "z$with_libxml" = "z" -a "z$PKG_CONFIG_ENABLED" = "zyes" ; then
> >
> >#    PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_MIN_VERSION,
> >#       LIBXML_FOUND=yes,
> >#       LIBXML_FOUND=no)
> >
> >I know that the libxml in my system is in correct version. the var
> >LIBXML_MIN_VERSION in configure script is set to "2.5.0". This is the
> >version in my system:
> ># dpkg -l | grep libxml2
> >ii  libxml2                2.6.27.dfsg-1                   GNOME XML
> >library
> >ii  libxml2-dev            2.6.27.dfsg-1                   Development
> >files for the GNOME XML library
> >
> >file: libvirt/tests/xencapstest.c
> >  /*  if (!(actualxml = xenHypervisorMakeCapabilitiesXML(NULL,
> >hostmachine, fp1, fp2)))
> >      goto fail;*/
> >
> >In libvirt/tests/xencapstest.c, I don't know if comment it is correct.
> >Any idea? I do it correctly? this test is important to libvirt?
> >
> >This is the return error if I not comment the conditional 'if' in
> >libvirt/tests/xencapstest.c:
> >
> >gcc -fno-stack-protector -o xencapstest xencapstest.o 
> >testutils.o../src/.libs/libvirt_la-
> >conf.o ../src/.libs/libvirt_la-hash.o 
> >../src/.libs/libvirt_la-libvirt.o../src/.libs/libvirt_la-proxy_internal.o
> >../src/.libs/libvirt_la-qemu_internal.o ../src/.libs/libvirt_la- 
> >sexpr.o../src/.libs/libvirt_la-
> >test.o 
> >../src/.libs/libvirt_la-virterror.o../src/.libs/libvirt_la-xend_internal.o
> >../src/.libs/libvirt_la-xen_internal.o 
> >../src/.libs/libvirt_la-xen_unified.o
> >../src/.libs/libvirt_la-xm_internal.o ../src/.libs/libvirt_la- 
> >xml.o../src/.libs/libvirt_la-xs_internal.o  -L/usr/lib /usr/lib/libxml2.so
> >xencapstest.o: In function `testCompareFiles':
> >xencapstest.c:(.text+0xb4): undefined reference to
> >`xenHypervisorMakeCapabilitiesXML'
> >collect2: ld returned 1 exit status
> >make[3]: ** [xencapstest] Erro 1


So, the only reason I can think that this would happen is if #if WITH_XEN
evaluated false. This can be for two reasons, either you asked for --without-xen,
or the configure script was not able to find the Xen development libs/headers.
The configure.log you supplied shows it was the latter:

checking for library containing xs_read... no
Xen store library not found


Make sure you have   libxen-dev  (or whatever debian calls it) - basically you
need to make sure you have

/usr/include/xs.h
/usr/lib/libxenstore.so

Available


NB, the compile error is also a bug in the build system - we should not be
building xen-specific tests, if the Xen support in the main library is not
being compiled.

Dan.,
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]