[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] virsh - vcpuinfo cmd not working in 0.2.2



On Thu, May 10, 2007 at 02:55:29PM +0200, Jan Michael wrote:
> Hi Daniel,
> 
> On 07.05.2007, at 22:06, Daniel P. Berrange wrote:
> >On Mon, May 07, 2007 at 10:13:57AM +0900, Atsushi SAKAI wrote:
> >>Hi, Jan
> >>
> >>I think you should use 0.2.1 at this moment.
> >>libvirt cannot handle Xen-hypervisor-domctl correctly on 0.2.2.
> >>But Xen-hypervisor-sysctl works fine.
> >>This problem recognized in two weeks ago,
> >> but I have no time to investigate this issue.
> >
> >I've been trying to reproduce / diagnose the problems you reported too
> >but not had much luck so far. Every way I look at it the code looks to
> >be using the correct hypercall numbers, operation numbers & structs.
> >Until I just noticed this:
> 
> Thank you for trying to tracking down this error.
> Even though I get the following error from virsh command line interface,
> 
> <error>
> [root xen-machine libvirt-0.2.1]# ./src/virsh
> libvir: error : no support for hypervisor
> lt-virsh: error: failed to connect to the hypervisor
> </error>

Can you re-run with

    strace -f -o virsh.log  ./srv/virsh

And send the resulting log file.

Also, can you run   'lsof -p <pid>'  for the PID which matches
xenstored, and the 2nd python XendD process.

# ps -axuwf | grep xen
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.7/FAQ
root        13  0.0  0.0      0     0 ?        S<   May08   0:00  \_ [xenwatch]
root        14  0.0  0.0      0     0 ?        S<   May08   0:00  \_ [xenbus]
root     30138  0.0  0.0  69080   712 pts/2    S+   09:23   0:00          \_ grep xen
root      3106  0.3  0.0   8396   900 ?        S    May08  10:08 xenstored --pid-file /var/run/xenstore.pid
root      3111  0.0  0.4 172968  9252 ?        S    May08   0:00 python /usr/sbin/xend start
root      3112  0.5  1.4 359856 29728 ?        Sl   May08  15:33  \_ python /usr/sbin/xend start
root      3114  0.0  0.0  20520   548 ?        Sl   May08   0:00 xenconsoled

You'd need to run

  lsof -p 3106
  lsof -p 3112

..as root.

> >The second thing is that we've just discovered a bug in the Fedora Xen
> >kernels 2.6.20 wrt to SMP which could cause random bad things to  
> >happen
> >So if you're using a Fedora 2.6.20 kernel it is also worth seeing  
> >if it
> >is still a problem with an older Fedora 2.6.19/18 kernel, or with the
> >vanilla upstream Xen
> 
> I'm not really shure about my kernel version and its origin because I  
> didn't compiled it myself. But it is very likely that my kernel is no  
> Fedora one because I use Scientific Linux.

At very least output from  'xm info'  will usefull

Regards,
Dan.
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]