[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] virsh - vcpuinfo cmd not working in 0.2.2



On Tue, May 15, 2007 at 09:26:25AM +0900, Atsushi SAKAI wrote:
> Hi, Rich
> 
> I am just a little time to do on this.
> If you have time, please do it.
> 
> Anyway Another way to solve this is 
> off the xen_internal.c function and on the xend_internal.c
> (This is just a templary.)

IIRC, you previously mentioned you were testing on Fedora rawhide
which (at the time) was based on Xen 3.0.4.

In the past week we've discovered the SMP support in rawhide was
broken on x86_64, and there was a very serious memory corruption 
bug on i386 kernel, and there was a uninitialized variable inmore
SMP code for both archs. So unless this problem can be reproduced
on the upstreawm xen kernels I'd put it down to a Fedora kernel
bug. Thus for further testing I'd recommend

  - Test against the vanillia 2.6.16 kernel from xen 3.0.4 release
  - Test against current rawhide which has fixed the kernel bugs
    and also updated to xen 3.0.5

Regards,
Dan.
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]