[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] [PATCH] Fix failure of virsh attach-disk (BZ346281)



On Tue, Nov 06, 2007 at 09:10:54AM +0900, Masayuki Sunou wrote:
> Hi
> 
> Virsh attach-disk fails when the disk is attached to domain.
> And error message displays that device_configure() failed.
>   # virsh attach-disk PV_RH51RC_12 /dev/hda8 xvdb --driver phy
>   libvir: Xen Daemon error : POST operation failed:
>   (xend.err'device_configure() takes exactly 2 arguments (3 given)')
> --> BZ346281 : https://bugzilla.redhat.com/show_bug.cgi?id=346281
> 
> This problem occurs because search of device ID of disk doesn't
> operate correctly.
> 
> This patch fixes it.
> And this fixes a little comment too.

 Okay, as usual, I really prefer if you could explain how the patch
actually work instead of just describing the symptoms you are trying
to fix. That said I think I understand how this work , asking the
xen store is probably the only reliable way to get the device ID
and we already do this for networking devices, so I guess the patch
is okay. But in the future please explain how the patches you send 
are supposed to work, this makes review way faster and the patches
are less likely to sit unverified in the list archives,

  patch applied and commited,

  thanks a lot !

Daniel

-- 
Red Hat Virtualization group http://redhat.com/virtualization/
Daniel Veillard      | virtualization library  http://libvirt.org/
veillard redhat com  | libxml GNOME XML XSLT toolkit  http://xmlsoft.org/
http://veillard.com/ | Rpmfind RPM search engine  http://rpmfind.net/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]