[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] Compiling libvirt v0.3.2 on centos5



Meng Kuan wrote:
Hi,

Here is what I did when I tried to upgrade the libvirt on my centos5 system to the latest version.

sudo yum install python-devel xen-devel libxml2-devel readline-devel gnutls-devel
  wget ftp://libvirt.org/libvirt/libvirt-0.3.2-1.src.rpm
  sudo rpmbuild --rebuild libvirt-0.3.2-1.src.rpm

It's best to avoid building RPMs as root. Set up a non-root RPM buildroot instead. If you have rpmdevtools package installed, then there should be a command "rpmdev-setuptree" which does this. Otherwise read these instructions:
http://genetikayos.com/code/repos/rpm-tutorial/trunk/rpm-tutorial.html

...
...
RPM build errors:
    InstallSourcePackage: Header V3 DSA signature: NOKEY, key ID de95bc1f
    user veillard does not exist - using root
    user veillard does not exist - using root
    Installed (but unpackaged) file(s) found:
   /usr/share/doc/libvirt-0.3.2/html/FAQ.html
   /usr/share/doc/libvirt-0.3.2/html/Libxml2-Logo-90x34.gif
   /usr/share/doc/libvirt-0.3.2/html/examples.xml
   /usr/share/doc/libvirt-0.3.2/html/examples.xsl
   /usr/share/doc/libvirt-0.3.2/html/html/book1.html
   /usr/share/doc/libvirt-0.3.2/html/html/home.png
   /usr/share/doc/libvirt-0.3.2/html/html/index.html
   /usr/share/doc/libvirt-0.3.2/html/html/left.png
   /usr/share/doc/libvirt-0.3.2/html/html/libvirt-bridge.html
   /usr/share/doc/libvirt-0.3.2/html/html/libvirt-conf.html
   /usr/share/doc/libvirt-0.3.2/html/html/libvirt-gnutls_1_0_compat.html
   /usr/share/doc/libvirt-0.3.2/html/html/libvirt-lib.html
   /usr/share/doc/libvirt-0.3.2/html/html/libvirt-libvirt.html
   /usr/share/doc/libvirt-0.3.2/html/html/libvirt-util.html
   /usr/share/doc/libvirt-0.3.2/html/html/libvirt-uuid.html
   /usr/share/doc/libvirt-0.3.2/html/html/libvirt-virterror.html
   /usr/share/doc/libvirt-0.3.2/html/html/right.png
   /usr/share/doc/libvirt-0.3.2/html/html/up.png
   /usr/share/doc/libvirt-0.3.2/html/info1.c
   /usr/share/doc/libvirt-0.3.2/html/libvir.html
   /usr/share/doc/libvirt-0.3.2/html/redhat.gif
   /usr/share/doc/libvirt-0.3.2/html/suspend.c
   /usr/share/doc/libvirt-python-0.3.2/TODO
   /usr/share/doc/libvirt-python-0.3.2/examples/basic.py
   /usr/share/doc/libvirt-python-0.3.2/examples/create.py
   /usr/share/doc/libvirt-python-0.3.2/examples/error.py
   /usr/share/doc/libvirt-python-0.3.2/examples/node.py
   /usr/share/doc/libvirt-python-0.3.2/examples/uuid.py

I think your best bet is to take a look at where it is installing these files. Find the RPM build root (usually /var/tmp/something) and do:
  find /var/tmp/something -type f

The compare that list of files with the one in the spec file.

I tried to get around this by putting the following in the ~/.rpmmacros file (according to this webpage http://www.rpm.org/hintskinks/unpackaged/):

  _unpackaged_files_terminate_build 0
  _missing_doc_files_terminate_build 0

However, that does not seem to help. Any ideas?

Should I just install the binary packages instead of building from source?

I must admit that I normally build from CVS, and on RHEL 5 that works just fine, so I can't see why it would work from Centos.

Rich.

--
Emerging Technologies, Red Hat - http://et.redhat.com/~rjones/
Registered Address: Red Hat UK Ltd, Amberley Place, 107-111 Peascod
Street, Windsor, Berkshire, SL4 1TE, United Kingdom.  Registered in
England and Wales under Company Registration No. 03798903

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]