[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] Compiling libvirt v0.3.2 on centos5



On Mon, Sep 03, 2007 at 02:07:33PM +0800, Meng Kuan wrote:
> Hi,
> 
> Here is what I did when I tried to upgrade the libvirt on my centos5  
> system to the latest version.
> 
>   sudo yum install python-devel xen-devel libxml2-devel readline- 
> devel gnutls-devel
>   wget ftp://libvirt.org/libvirt/libvirt-0.3.2-1.src.rpm
>   sudo rpmbuild --rebuild libvirt-0.3.2-1.src.rpm

Make sure you have 'redhat-rpm-config' installed too - its a standard part
of the build roots for all RHEL packages & defines alot of RPM macros to
change build of various aspects of the build. If that wasn't present you 
can get all sorts of utterly bizzarre errors.

Also, *never* build RPMs as root. It is a perfect way to completely and
utterly trash your system.

As non root create  $HOME/.rpmmacros

   %_topdir /home/myusername/rpm

And then create


  mkdir $HOME/rpm
  mkdir $HOME/rpm/{RPMS,SRPMS,SOURCES,SPECS,BUILD}
  mkdir $HOME/rpm/RPMS/{noarch,i386,i686,x86_64}

> I tried to get around this by putting the following in the  
> ~/.rpmmacros file (according to this webpage http://www.rpm.org/ 
> hintskinks/unpackaged/):

You are build as root - so a $HOME/.rpmmacros file isn't going to have any
effect

Dan.
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]