[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvir] can't start windows guest domains



Hi.

I'm running F7 x86_64 with kernel 2.6.20-2931.fc7xen and libvirt-0.3.2-1.fc7. Since i updated to the latest versions i can't start any windows domains anymore. I thought undefine and reinstall the domains could resolve the problem, but i get the exact same error message.
There is also a F7 x86_64 guest domain runnning fine on the same host.
Why i can't start any windows domains anymore?


[thomas srv1 ~]$ sudo virt-install -d -n sbs -r 512 --vcpus=1 -f /dev/VolGroup01/sbs -w bridge:virbr0 --vnc -k DE -v --arch=i386 --os-type=windows --os-variant=win2k3 -c /var/www/html/install/SBS2003R2DE_DVD.iso

Mon, 10 Sep 2007 20:38:28 DEBUG Path is block file: Assuming Block disk type. Disk /dev/VolGroup01/sbs is already in use by another guest! Do you really want to use the disk (yes or no)? y


Starting install...
libvir: Xen Daemon error : GET operation failed:
libvir: Xen Daemon error : GET operation failed:
Mon, 10 Sep 2007 20:38:31 DEBUG    Creating guest from '<domain type='xen'>
  <name>sbs</name>
  <currentMemory>524288</currentMemory>
  <memory>524288</memory>
  <uuid>5f73764f-897c-401c-e9e5-17cb21333334</uuid>
  <os>
    <type arch='i386'>hvm</type>
    <loader>/usr/lib/xen/boot/hvmloader</loader>
    <boot dev='cdrom'/>
  </os>
  <features>
    <apic/><acpi/><pae/>
  </features>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <vcpu>1</vcpu>
  <devices>
    <emulator>/usr/lib64/xen/bin/qemu-dm</emulator>
    <console device='pty'/>
    <disk type='block' device='disk'>
      <source dev='/dev/VolGroup01/sbs'/>
      <target dev='hda'/>
    </disk>
    <disk type='file' device='cdrom'>
      <source file='/var/www/html/install/SBS2003R2DE_DVD.iso'/>
      <target dev='hdc'/>
      <readonly/>
    </disk>

    <interface type='bridge'>
      <source bridge='virbr0'/>
      <mac address='00:16:3e:33:eb:7b'/>
    </interface>

    <graphics type='vnc' port='-1' keymap='DE' />
  </devices>
</domain>
'
libvir: Xen Daemon error : POST operation failed: (xend.err "Error creating domain: (12, 'Cannot allocate memory')") virDomainCreateLinux() failed POST operation failed: (xend.err "Error creating domain: (12, 'Cannot allocate memory')")
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start sbs'; otherwise, please
 restart your installation.
Mon, 10 Sep 2007 20:38:31 ERROR virDomainCreateLinux() failed POST operation failed: (xend.err "Error creating domain: (12, 'Cannot allocate memory')")
Traceback (most recent call last):
  File "/usr/bin/virt-install", line 474, in <module>
    main()
  File "/usr/bin/virt-install", line 438, in main
    dom = guest.start_install(conscb,progresscb)
File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 710, in start_install
    return self._do_install(consolecb, meter)
File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 727, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
File "/usr/lib64/python2.5/site-packages/libvirt.py", line 563, in createLinux if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self) libvirtError: virDomainCreateLinux() failed POST operation failed: (xend.err "Error creating domain: (12, 'Cannot allocate memory')")


[thomas srv1 ~]$ free
           total       used       free     shared    buffers     cached
Mem:       6154240    1312276    4841964          0     144660     600632
-/+ buffers/cache:     566984    5587256
Swap:      8323064          0    8323064



kind regards,
Thomas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]