[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] can't start windows guest domains



On Tue, Sep 11, 2007 at 06:51:29PM +0200, Thomas Antony wrote:
> >>I'm running F7 on a Dell PE2950 with 8GB RAM.
> >>It would be nice if you could explain how much RAM i should allocate 
> >>to Dom0 and what are the minimum requirements for Dom0.
> >
> >I would expect that allocating 512 MB to Dom0 as you did should be 
> >sufficient (unless it's running a huge database or something like that).
> >
> >The problem, though, isn't likely to be the allocation, but the fact 
> >that you are using 'virsh setmaxmem' to balloon it down from something 
> >larger to 512 MB.  In any case, I'm not sure what the problem is - 
> >unless you can find something in a logfile, it's hard to tell.
> >
> 
> After i allocated 512MB RAM to Dom0 the kernel printed many out of 
> memory messages like this and began to kill services.

Well pretty clearly then you are running so many processes in Dom0 that
you need more than just 512 MB for Dom0. This isn't a bug in libvirt, you
merely reduced the RAM available to below that which is needed for the
set of applications you are running.

Dan.
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]