[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvir] [PATCH] Ancient libparted



Some of us are stuck with an ancient libparted, which doesn't know about
PED_PARTITION_PROTECTED. This patch allows us to compile libvirt.


=== modified file 'src/parthelper.c'
--- src/parthelper.c	2008-04-10 16:53:29 +0000
+++ src/parthelper.c	2008-04-29 07:47:08 +0000
@@ -67,8 +67,10 @@
                 content = "free";
             else if (part->type & PED_PARTITION_METADATA)
                 content = "metadata";
+#ifdef PED_PARTITION_PROTECTED
             else if (part->type & PED_PARTITION_PROTECTED)
                 content = "protected";
+#endif
             else
                 content = "data";
         } else if (part->type == PED_PARTITION_EXTENDED) {
@@ -80,8 +82,10 @@
                 content = "free";
             else if (part->type & PED_PARTITION_METADATA)
                 content = "metadata";
+#ifdef PED_PARTITION_PROTECTED
             else if (part->type & PED_PARTITION_PROTECTED)
                 content = "protected";
+#endif
             else
                 content = "data";
         }


-- 
Soren Hansen               | 
Virtualisation specialist  | Ubuntu Server Team
Canonical Ltd.             | http://www.ubuntu.com/

Attachment: signature.asc
Description: Digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]