[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] fail to run virsh



On Fri, Aug 15, 2008 at 4:21 PM, Daniel P. Berrange <berrange redhat com> wrote:
> On Thu, Aug 14, 2008 at 05:27:14PM +0900, Jun Koi wrote:
>> Hi,
>>
>> I installed libvirt (cvs version), and can confirm that libvirtd is
>> running. However, virsh failed to work. I got the below message when
>> running virsh with debugging information.
>
>
>> # LIBVIRT_DEBUG=1 virsh
>> DEBUG: libvirt.c: virInitialize (register drivers)
>
> ...
>
>> DEBUG: libvirt.c: do_open (trying driver 5 (remote) ...)
>> DEBUG: remote_internal.c: doRemoteOpen (proceeding with name = qemu:///system)
>> libvir: Remote error : No such file or directory
>
> This suggests that its not able to connect to the daemon. Are you using the
> version of virsh that matches the libvirtd daemon you compiled ? If you
> have a pre-built virsh from your distro installed, and then do a CVS build
> with a different '--prefix' to configure that could explain this.

I tried to recompile libvirt cvs again, then got this error:


./.libs/libvirt.so: undefined reference to `xenUnifiedRegister'
./.libs/libvirt.so: undefined reference to `xenUnifiedRegister'
collect2: ld returned 1 exit status
make[3]: *** [virsh] Error 1


I searched around, but dont see how to fix this. (this is on Ubuntu 8.04)

Thank you,
Jun


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]