[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] storage pool discovery



On Fri, Aug 22, 2008 at 10:58:54AM -0400, David Lively wrote:
> On Fri, 2008-08-22 at 09:50 +0100, Daniel P. Berrange wrote:
> > > +    const char *start_tag = "<SourceList>\n";
> > > +    const char *end_tag = "</SourceList>\n";
> > 
> > I'd prefer that to be  <sources>  - we avoid capitals in the
> > XML element names everywhere else, and in the few cases of
> > joining words use an underscore, but I think plural form is
> > OK for this.
> 
> I prefer <sources> as well, so I'll change this.  And I'll put those
> defines in storage_backend.h as well.
> 
> As long as we're on the subject of naming (and before it's too late),
> it's been bothering me that we keep calling this "storage pool
> discovery".  To me, "storage source discovery" seems more accurate
> (because they're not pools until we define libvirt pools based on the
> sources).  So I'd prefer renaming the various *Discover[Storage]Pools*
> functions (and support structs) introduced in this patch to
> *Discover[Storage]Sources*.  I was just sticking with the
> originally-proposed names to avoid confusion.  What do you all think?

That sounds like a reasonable idea to me.

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]