[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirt 0.5.0 and KVM migration



Thanks for your quick answer.

I forgot to restart libvirt on one node.

Now I have an other error message:

libvir: QEMU error : operation failed: failed to start listening VM

Is there any kernel limitation also ? will it work with my distro 2.6.26
kernel with kvm-79 userspace component or do I have to have kvm-79
kernel module also, or even kernel then 2.6.26 ?

In other (debian) words, will an "apt-get update kvm -t
experimental" (which provides kvm-79) be enough on my lenny (I would
like to limit unstable or experimental packages) ?

Thanks

On Mon, 2008-12-01 at 15:12 +0100, Chris Lalancette wrote:
> Mickaël Canévet wrote:
> > Hi,
> > 
> > I just installed libvirt 0.5.0 on Debian Lenny with KVM 0.72 to try KVM
> > migration support.
> > 
> > When I try to migrate a VM from one node to the other one, I have this
> > error message:
> > 
> > libvir: error : this function is not supported by the hypervisor:
> > virDomainMigrate
> > 
> > Is it really supposed to work ? Do I have to upgrade KVM to a newer
> > version ?
> 
> Yes, it is supposed to work, but yes, you need a very, very new KVM.  In
> particular, you need at least kvm-77, and it won't really work right until you
> get to kvm-79.
> 
-- 
_______________________________________________________________________
Mickaël Canévet.
European Molecular Biology Laboratory (EMBL)
Grenoble Outstation. FRANCE
_______________________________________________________________________

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]