[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Doubt over Kvm migration support in libvirt 0.5.0



I am using libvirt(python) to develop a small application which will
manage my nodes which running in KVM.
But when i tried migration i got this error.

>>> vs.migrate(conn, libvirt.VIR_MIGRATE_LIVE,'testtt','192.168.1.82',0)
libvir: error : this function is not supported by the hypervisor:
virDomainMigrate
Traceback (most recent call last):
 File "<stdin>", line 1, in ?
 File "/usr/lib64/python2.4/site-packages/libvirt.py", line 301, in migrate
   if ret is None:raise libvirtError('virDomainMigrate() failed', dom=self)
libvirt.libvirtError: virDomainMigrate() failed this function is not
supported by the hypervisor: virDomainMigrate


i am running kvm-66 taken from Centos-5 Testing repositary and libvirt
0.5.0( 0.5.0: Nov 25 2008 release note says that support for kvm
migration included)

i am bit confused after reading this... Please any one help me in this.

Thanks and Regards,
-Shan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]