[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] fix size parameter in calls to numa_node_to_cpus



On Thu, Dec 11, 2008 at 07:43:01PM +0000, Daniel P. Berrange wrote:
> On Thu, Dec 11, 2008 at 01:56:47PM -0500, Dave Allan wrote:
> > I was getting the error:
> > 
> > map size mismatch; abort
> > 
> > when running the daemon-conf tests.
> > 
> > I traced it to two places in which we were passing a parameter as a 
> > number of bits to numa_node_to_cpus which expects a number of bytes (see 
> > numa_node_to_cpus_compat in numa.h in the numactl source).
> 
> I'm still very puzzelled by this. What OS and architecture are you
> running on ?
> 
> I'm using Fedora 10, x86_64 and don't see any messages with current
> CVS and it returns NUMA info correctlys (as per virsh capabilities)

  I saw the problem too on one machine, it broke make check  ,
  coincidentally it s also an F-10 x86_64 :-)

 138) xml2sexprdata/xml2sexpr-fv-sound.xml  OK
Validated 138 files, 0 failed
PASS: domainschematest
 1) fc4.conf
... OK
 2) libvirtd.conf
... OK
PASS: test_conf.sh
PASS: cpuset
/u/veillard/libvirt/tests/daemon-conf-30173
testing with corrupted config: listen_tls
--- expected-err    2008-12-12 11:30:30.000000000 +0100
+++ err 2008-12-12 11:30:30.000000000 +0100
@@ -1,2 +1,5 @@
+map size mismatch; abort
+: Success
+umlStartup: out of memory
 remoteReadConfigFile: in1.conf: listen_tls: invalid type: got string;
expected long
 
testing with corrupted config: listen_tcp
--- expected-err    2008-12-12 11:30:30.000000000 +0100
+++ err 2008-12-12 11:30:30.000000000 +0100
@@ -1,2 +1,5 @@
+map size mismatch; abort
+: Success
+umlStartup: out of memory
 remoteReadConfigFile: in2.conf: listen_tcp: invalid type: got string;
expected long
 
testing with corrupted config: tls_port
--- expected-err    2008-12-12 11:30:30.000000000 +0100
+++ err 2008-12-12 11:30:30.000000000 +0100
@@ -1,2 +1,5 @@
+map size mismatch; abort
+: Success
+umlStartup: out of memory
 remoteReadConfigFile: in3.conf: tls_port: invalid type: got long;
expected string
 
testing with corrupted config: tcp_port

 etc ....

 and with the patch everything works again on that machine (Intel core
 duo with 2GB memory). Still I hope we were not allocating a gigabyte of
memory for that call (if yes there is a serious fix needed even with a
factor of 8 less).

  So applied and commited, thanks a lot, but I'm still puzzled, why did
we end out of memory, I will look quickly

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]