[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] libvirtd crashing with network bridge configuration



Dear Developers, Users,

I'm trying to package libvirt for our distribution, however, having some problems past the libvirt 0.4.3 series.  Everything compiles and installs fine.

With versions above and including 0.5.1, I'm getting the following errors in the dmesg output:

virbr0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.                                      
virbr0: starting userspace STP failed, starting kernel STP                                          
sysfs: duplicate filename '0' can not be created                                                    
------------[ cut here ]------------                                                                
WARNING: at fs/sysfs/dir.c:424 sysfs_add_one+0x34/0xa6()                                            
Modules linked in: ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 xt_state nf_conntrack ipt_REJECT xt_tcpudp iptable_filter ip_tables x_tables microcode firmware_class acpi_cpufreq cpufreq_powersave cpufreq_userspace ipv6 bridge fuse loop tun kvm_intel kvm coretemp w83627ehf hwmon_vid hwmon snd_hda_intel nvidia(P) snd_seq_dummy snd_seq_oss snd_seq_midi_event joydev snd_seq rtc_cmos rtc_core rtc_lib snd_seq_device i2c_i801 iTCO_wdt usbhid serio_raw snd_pcm_oss snd_mixer_oss hid iTCO_vendor_support snd_pcm ff_memless snd_timer snd_page_alloc thermal atl1 snd_hwdep processor intel_agp snd button mii agpgart i2c_core soundcore sg ext3 jbd mbcache raid456 async_xor async_memcpy async_tx xor raid10 raid1 raid0 dm_mod sd_mod sr_mod cdrom usb_storage pata_jmicron ehci_hcd uhci_hcd usbcore ohci1394 ieee1394 pata_acpi ahci ata_generic libata scsi_mod dock                                              
Pid: 3605, comm: libvirtd Tainted: P         2.6.25.20-113 #1                                       
 [<c02d60e6>] ? printk+0xf/0x11                                                                     
 [<c0122e01>] warn_on_slowpath+0x41/0x67                                                            
 [<c01dbae8>] ? vsnprintf+0x287/0x40f                                                               
 [<c012352e>] ? release_console_sem+0x194/0x19c                                                     
 [<c01d7e32>] ? ida_get_new_above+0xd0/0x171                                                        
 [<c0185afb>] ? find_inode+0x1f/0x5b                                                                
 [<c01afde8>] ? sysfs_ilookup_test+0x0/0x11                                                         
 [<c0185bfb>] ? ifind+0x32/0x76                                                                     
 [<c01b00ca>] sysfs_add_one+0x34/0xa6                                                               
 [<c01b05b2>] create_dir+0x43/0x72                                                                  
 [<c01b060e>] sysfs_create_dir+0x2d/0x41                                                            
 [<c01d85de>] ? kobject_get+0x12/0x17                                                               
 [<c01d86dc>] kobject_add_internal+0xa9/0x14a                                                       
 [<c01d8811>] kobject_add_varg+0x35/0x41                                                            
 [<c01d883d>] kobject_init_and_add+0x20/0x22                                                        
 [<c012ae70>] uids_user_create+0x36/0x5b                                                            
 [<c012b028>] alloc_uid+0xf3/0x1b6
 [<c01486c6>] copy_user_ns+0x59/0xaf
 [<c0136833>] create_new_namespaces+0xe9/0x196
 [<c013697e>] copy_namespaces+0x45/0x73
 [<c0122152>] copy_process+0xba9/0x11e5
 [<c012283d>] do_fork+0xaf/0x1e4
 [<c0103428>] sys_clone+0x1f/0x21
 [<c0104a2e>] syscall_call+0x7/0xb
 [<c02d0000>] ? pci_fixup_msi_k8t_onboard_sound+0x68/0x98
 =======================
---[ end trace e8211acaf4c7288d ]---
kobject_add_internal failed for 0 with -EEXIST, don't try to register things with the same name in the same directory.
Pid: 3605, comm: libvirtd Tainted: P         2.6.25.20-113 #1
 [<c01d876b>] kobject_add_internal+0x138/0x14a
 [<c01d8811>] kobject_add_varg+0x35/0x41
 [<c01d883d>] kobject_init_and_add+0x20/0x22
 [<c012ae70>] uids_user_create+0x36/0x5b
 [<c012b028>] alloc_uid+0xf3/0x1b6
 [<c01486c6>] copy_user_ns+0x59/0xaf
 [<c0136833>] create_new_namespaces+0xe9/0x196
 [<c013697e>] copy_namespaces+0x45/0x73
 [<c0122152>] copy_process+0xba9/0x11e5
 [<c012283d>] do_fork+0xaf/0x1e4
 [<c0103428>] sys_clone+0x1f/0x21
 [<c0104a2e>] syscall_call+0x7/0xb
 [<c02d0000>] ? pci_fixup_msi_k8t_onboard_sound+0x68/0x98
 =======================
virbr0: no IPv6 routers present


ps ax shows the following output right after the service is started:

 3605 ?        S      0:00 /usr/sbin/libvirtd --daemon
 3624 ?        Z      0:00 [libvirtd] <defunct>

If I don't enable any network at  /etc/libvirt/qemu/networks/autostart, then there's no error.

Any clues are appreciated, I'm unable to proceed with it.

Best Regards.

Emre

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]