[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 3/7] New configure option --with-rhel5-api



On Tue, Dec 23, 2008 at 05:50:03PM +0000, John Levon wrote:
> On Tue, Dec 23, 2008 at 04:05:13PM +0100, Markus Armbruster wrote:
> 
> > RHEL-5 has a peculiar version of Xen, which requires some special
> > casing.  Add a configure option for that.  It will be used in later
> > commits.
> 
> Ugh, shouldn't this be staying in a private Red Hat repository?

This has been our approach up until now. It has turned out to cause more
trouble than its solves though. Various people want to try out & user the
newer libvirt on RHEL-5 hosts than the version we ship in RHEL-5. The
current libvirt releases don't entirely work on RHEL-5 , due to fact that
RHEL-5 Xen has backported a number of newer features. Adding this new
--with-rhel5-api is a compromise - we target official Xen releases by
default, but if you pass this flag at build time it'll enable the extra
features backported to RHEL-5 Xen.

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]