[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvir] Error compiling libvirt 0.4.0 on debian etch



Hi, when I'm trying to compile the libvirt 0.4.0 on Debian etch I'm getting the error below, I have no problem with version 0.3.3.

I've look at line 578 of
/usr/include/xen/xen.h and this error don't make sense for me. Does any anyone had this problem on debian etch too ? Maybe someone can help-me with this error ?

Thanks for attention,

Solli Honorio

<error>
....
In file included from /usr/include/xen/dom0_ops.h:31,
                 from xen_unified.c:29:
/usr/include/xen/xen.h:578: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'char'
/usr/include/xen/xen.h:579: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'short'
/usr/include/xen/xen.h:580: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'int'
/usr/include/xen/xen.h:581: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'long'
make[2]: *** [libvirt_la-xen_unified.lo] Error 1
make[2]: Leaving directory `/usr/src/libvirt-0.4.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/libvirt-0.4.0'
make: *** [all] Error 2
</error>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]