[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] libvirt on OS X Leopard 10.5.1



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Okay, the autogen.sh fails right off the bat. To get it working you have to edit it so that it checks the ld version with a '-V' instead of '--version' (OS X specific). Once you do that and run:

./autogen.sh --without-xen --without-qemu

it trucks along nicely until:

./configure: line 35741: syntax error near unexpected token `libxml-2.0,LIBXML_FOUND=yes' ./configure: line 35741: ` PKG_CHECK_EXISTS(libxml-2.0,LIBXML_FOUND=yes)'

Line 35721 of the generated configure script begins:

PKG_PROG_PKG_CONFIG

LIBXML_CONFIG="xml2-config"
LIBXML_CFLAGS=""
LIBXML_LIBS=""
LIBXML_FOUND="no"


# Check whether --with-libxml was given.
if test "${with_libxml+set}" = set; then
  withval=$with_libxml;
fi

if test "z$with_libxml" = "zno" ; then
{ echo "$as_me:$LINENO: checking for libxml2 libraries >= $LIBXML_REQUIRED" >&5 echo $ECHO_N "checking for libxml2 libraries >= $LIBXML_REQUIRED... $ECHO_C" >&6; } { { echo "$as_me:$LINENO: error: libxml2 >= $LIBXML_REQUIRED is required for libvirt" >&5 echo "$as_me: error: libxml2 >= $LIBXML_REQUIRED is required for libvirt" >&2;}
   { (exit 1); exit 1; }; }
elif test "z$with_libxml" = "z" -a "x$PKG_CONFIG" != "x" ; then
    PKG_CHECK_EXISTS(libxml-2.0,LIBXML_FOUND=yes)
    if test "$LIBXML_FOUND" != "no" ; then
        PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_REQUIRED)
    fi
fi

Looks like some stand-in values are not getting replaced when the configure script is generated. Ideas?

- --
- -a


On Jan 21, 2008, at 5:27 PM, Schley Andrew Kutz wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Ah, I knew hyper was 64-bit, but it has no definition on OS X. I thought that long on OS X 10.5.1 was 64 bits in width -- my mistake.

There wre two bugs in the remoteAuthenticate method in libvirt 0.4.0 which can cause crashes. I'd recommend testing again with libvirt from the latest
CVS checkout - its pretty likely that'll fix your problem.

The funny thing is that I have all auth mechanisms turned off in libvirtd. But I can see how some of the library's init code may be failing. I did try to build the package from HEAD, but that failed. I will try again and report the errors.

Thanks!

- --
- -a


On Jan 21, 2008, at 5:20 PM, Daniel P. Berrange wrote:

On Mon, Jan 21, 2008 at 04:50:29PM -0600, Schley Andrew Kutz wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I spent the weekend attempting to get libvirt working on OS X Leopard
10.5.1. I was able to get it to compile, but not connect to libvirtd
running on either my KVM or Xen servers. Here are the instructions for
getting it to compile:

1. Download libvirt-0.4.0 from the mirrors.

2. Use macports to install pkgconfig and gnutls

3. Configure your source:

./configure --without-xen --without-qemu

4. Replace instances of 'hyper' in qemu/remote_protocol.x with 'long' and then follow the instructions on http://libvirt.org/ windows.html to
regen XDR structures.

This is going to fail big time. 'hyper' is 64-bit in size, where
as long is 32-bit. Any RPC calls which user hyper will crash and
burn if you make this change.

What errors do you get if you don't make this change ? There may
be better ways to provide compatability.

10. The sources should now build and install.

At this point any attempt to connect to a remote host results in the
thread dying and OS X catching the exception with the following report:

<beginReport>
Process:         Python [57356]
Path: /System/Library/Frameworks/Python.framework/ Versions/
2.5/Resources/Python.app/Contents/MacOS/Python
Identifier:      Python
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  bash [59098]

Date/Time:       2008-01-21 16:48:52.228 -0600
OS Version:      Mac OS X 10.5.1 (9B18)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000004
Crashed Thread:  0

Thread 0 Crashed:
0   libvirt.0.dylib               	0x00412911 remoteAuthenticate +
1345 (remote_internal.c:3062)

There wre two bugs in the remoteAuthenticate method in libvirt 0.4.0 which can cause crashes. I'd recommend testing again with libvirt from the latest
CVS checkout - its pretty likely that'll fix your problem.

Regards,
Dan.
--
|=- Red Hat, Engineering, Emerging Technologies, Boston. +1 978 392 2496 -=| |=- Perl modules: http://search.cpan.org/ ~danberr/ -=| |=- Projects: http://freshmeat.net/ ~danielpb/ -=| |=- GnuPG: 7D3B9505 F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 -=|

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (Darwin)

iD8DBQFHlSplTg8lceyAqqQRAtk7AKCGcGnPEKJIHYmOy28nNVKtq4k1qgCffMYd
1ReRbsHTUqtPODeBgcCKhHo=
=86Kw
-----END PGP SIGNATURE-----

--
Libvir-list mailing list
Libvir-list redhat com
https://www.redhat.com/mailman/listinfo/libvir-list

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (Darwin)

iD8DBQFHlSuRTg8lceyAqqQRAgnOAKDeAAJoeVu+WOzM2W7fXbXpwgYZlACfa6ao
4+5tDMQEHSIetjA3CdC5O8w=
=qb2c
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]