[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] libvirt on OS X Leopard 10.5.1



On Mon, Jan 21, 2008 at 05:32:33PM -0600, Schley Andrew Kutz wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Okay, the autogen.sh fails right off the bat. To get it working you  
> have to edit it so that it checks the ld version with a '-V' instead  
> of '--version' (OS X specific). Once you do that and run:
> 
> ./autogen.sh --without-xen --without-qemu

Running autogen.sh requires that you have all optional software installed
and pkg-config files for them present. If you're missing any software then
it is unlikely to work. Rather than running autogen.sh on Mac OS, I'd 
recommend running it on Linux and creating yourself a snapshot tar.gz.

  eg

      ./autogen.sh   
      make dist

This should give you a libvirt-0.4.0.tar.gz containing a snapshot of CVS,
which you can the copy over to Mac OS & run configure normally as before. 


I would point you at the snapshot tar.gz here, but it appears to be not
updated since September

  http://libvirt.org/downloads.html

Regards,
Dan.
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]