[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Problem building RPM on x86_64



On Mon, Jul 21, 2008 at 10:59:17AM -0400, Darryl L. Pierce wrote:
> Daniel Veillard wrote:
> >>make[2]: Leaving directory 
> >>`/home/mcpierce/Programming/libvirt/gnulib/tests'
> >>make[2]: Entering directory `/home/mcpierce/Programming/libvirt/python'
> >>make[2]: *** No rule to make target `libvirt-py.c', needed by `distdir'. 
> >> Stop.
> >>make[2]: Leaving directory `/home/mcpierce/Programming/libvirt/python'
> >>make[1]: *** [distdir] Error 1
> >>make[1]: Leaving directory `/home/mcpierce/Programming/libvirt'
> >>make: *** [rpm] Error 2
> >>
> >>However, on i386 the build works just fine.
> >
> >  There is nothing arch specific there. Can you check the output of
> >configure and find if it detected Python development environment ?
> 
> python-devel was not installed and, while configure detected the following:
> 
> checking for ped_device_read in -lparted... no
> checking for python... /usr/bin/python
> Found Python version 2.5
> could not find python2.5/Python.h
> checking whether this host is running a Xen kernel... no
> 
> However, it didn't error out on it.

Because missing python is not an error - it is optional for regular
users build and install. If you want to build RPMs though you must have
everything installed.

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]