[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] network unreachable on XEN guest



I created a new network based on the default network.  However the network
is unreachable to the XEN guest.
I used net-dumpxml to print the "default" xml.  I changed the network XML
network name, bridge name, and uuid
and successfully created a new network.  I replaced source network
attribute in the domain creation XML to point to the new network name.

However, the guest can not properly initialize eth0 because the new network
is unreachable.
It tries to ping the ip assigned to the new bridge but fails.  The  same
guest created with the default network works
fine, i.e. it can access the network.

This what network restart looks like on the guest (I'm not sure if this
will be visible on the forum):

(Embedded image moved to file: pic26442.jpg)


This is a copy of the network XML:

<network>
  <name>test-net1</name>
  <uuid>7cfbfa88-542f-44c7-bbc1-3e19f67d8ca6</uuid>
  <forward mode='nat'/>
  <bridge name='test-br1' stp='on' forwardDelay='0' />
  <ip address='192.168.122.1' netmask='255.255.255.0'>
    <dhcp>
      <range start='192.168.122.2' end='192.168.122.254' />
    </dhcp>
  </ip>
</network>

This the interface segment domain creation XML:

    <interface type='network'>
      <!--source network='default'/-->
      <source network='test-net1'/>
      <script path='vif-bridge'/>
    </interface>

 This is the relevant ifconfig on host:
....
test-br1  Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet addr:192.168.122.1  Bcast:192.168.122.255
Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:81 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:9768 (9.5 KiB)  TX bytes:5018 (4.9 KiB)

vif13.0   Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:90 errors:0 dropped:0 overruns:0 frame:0
          TX packets:194 errors:0 dropped:2771 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:11136 (10.8 KiB)  TX bytes:10122 (9.8 KiB)

virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:192.168.122.1  Bcast:192.168.122.255
Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:365 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3291 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:34127 (33.3 KiB)  TX bytes:512877 (500.8 KiB)

This the brctl show output:

bridge name     bridge id               STP enabled     interfaces
br1             8000.000000000000       no
eth1            8000.001a64a12e56       no              peth1
test-br1                8000.feffffffffff       yes             vif13.0
virbr0          8000.000000000000       yes

What am I missing?

Thanks in advance.
-Kenneth Nagin

Attachment: pic26442.jpg
Description: JPEG image


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]