[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Fix qemudParseVMDeviceDef() to check for proper network device tag name



On Thu, Jun 12, 2008 at 09:22:20AM -0700, Kaitlin Rupert wrote:
> Is it too late to get this change in?

  Sorry, off by a couple of hours !

> Instead of "net", the tag name should be "interface".  Previously, 
> attempting to attach a network device to a KVM guest would return:
> 
> libvir: QEMU error : XML description for unknown device type is not well 
> formed or invalid
> error: Failed to attach device from attach-disk.xml
> 
> With this fix, it returns:
> 
> libvir: QEMU error test_domain: this function is not supported by the 
> hypervisor: only CDROM disk devices can be attached
> libvir: QEMU error : this function is not supported by the hypervisor: 
> only CDROM disk devices can be attached
> error: Failed to attach device from attach-disk.xml

  Hum, right a network device description uses "interface", not "net"
that's clear from both the doc and qemudParseXML(), so applied and 
commited, but infortunately it didn't made into 0.4.3 :-\

  thanks !

Daniel

-- 
Red Hat Virtualization group http://redhat.com/virtualization/
Daniel Veillard      | virtualization library  http://libvirt.org/
veillard redhat com  | libxml GNOME XML XSLT toolkit  http://xmlsoft.org/
http://veillard.com/ | Rpmfind RPM search engine  http://rpmfind.net/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]