[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Fix qemudParseVMDeviceDef() to check for proper network device tag name



On Fri, Jun 13, 2008 at 03:57:05AM -0400, Daniel Veillard wrote:
> On Thu, Jun 12, 2008 at 09:22:20AM -0700, Kaitlin Rupert wrote:
> > Is it too late to get this change in?
> 
>   Sorry, off by a couple of hours !
> 
> > Instead of "net", the tag name should be "interface".  Previously, 
> > attempting to attach a network device to a KVM guest would return:
> > 
> > libvir: QEMU error : XML description for unknown device type is not well 
> > formed or invalid
> > error: Failed to attach device from attach-disk.xml
> > 
> > With this fix, it returns:
> > 
> > libvir: QEMU error test_domain: this function is not supported by the 
> > hypervisor: only CDROM disk devices can be attached
> > libvir: QEMU error : this function is not supported by the hypervisor: 
> > only CDROM disk devices can be attached
> > error: Failed to attach device from attach-disk.xml
> 
>   Hum, right a network device description uses "interface", not "net"
> that's clear from both the doc and qemudParseXML(), so applied and 
> commited, but infortunately it didn't made into 0.4.3 :-\

That's not critical - this function is only called from the device hotplug
driver API, and we only implement that for changing CDROM media in QEMU
at the moment. So nothing we actually use for real is broken.

Regards,
Daniel.
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]