[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvir] Could not connect to xend



Hi.

When I tried to run virsh to connect to xen, I have got an error --- libvirt failed to open connection to xend.
Here is output with DEBUG enabled. What kind of additional information do you need?

[root localhost ~]# LIBVIRT_DEBUG=SPAM virsh
DEBUG: libvirt.c: virInitialize (register drivers)
DEBUG: libvirt.c: virConnectOpenAuth (name=(null), auth=0xb7ed79d8, flags=0)
DEBUG: libvirt.c: do_open (Probed xen:///)
DEBUG: libvirt.c: do_open (Using xen:/// as default URI, 1 hypervisor found)
DEBUG: libvirt.c: do_open (name "xen:///" to URI components:
  scheme xen
  opaque (null)
  authority (null)
  server (null)
  user (null)
  port 0
  path /
)
DEBUG: libvirt.c: do_open (trying driver 0 (Test) ...)
DEBUG: libvirt.c: do_open (driver 0 Test returned DECLINED)
DEBUG: libvirt.c: do_open (trying driver 1 (QEMU) ...)
DEBUG: libvirt.c: do_open (driver 1 QEMU returned DECLINED)
DEBUG: libvirt.c: do_open (trying driver 2 (Xen) ...)
DEBUG: xen_unified.c: xenUnifiedOpen (trying Xen sub-driver 0)
DEBUG: xen_unified.c: xenUnifiedOpen (Xen sub-driver 0 open ok
)
DEBUG: xen_unified.c: xenUnifiedOpen (trying Xen sub-driver 2)
libvir: Xen Daemon error : internal error failed to connect to xend
libvir: Xen Daemon error : internal error failed to connect to xend
DEBUG: xen_unified.c: xenUnifiedOpen (Xen sub-driver 2 open failed
)
DEBUG: libvirt.c: do_open (driver 2 Xen returned ERROR)
DEBUG: hash.c: virUnrefConnect (unref connection 0x807bf88 xen:/// 1)
DEBUG: hash.c: virReleaseConnect (release connection 0x807bf88 xen:///)
error: failed to connect to the hypervisor


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]