[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvir] Could not connect to xend



On Tue, Mar 11, 2008 at 05:23:24PM +0300, Anton Protopopov wrote:
> Hi.
> 
> When I tried to run virsh to connect to xen, I have got an error --- libvirt
> failed to open connection to xend.
> Here is output with DEBUG enabled. What kind of additional information do
> you need?
> 
> [root localhost ~]# LIBVIRT_DEBUG=SPAM virsh
[snip]
> DEBUG: libvirt.c: do_open (trying driver 2 (Xen) ...)
> DEBUG: xen_unified.c: xenUnifiedOpen (trying Xen sub-driver 0)
> DEBUG: xen_unified.c: xenUnifiedOpen (Xen sub-driver 0 open ok
> )
> DEBUG: xen_unified.c: xenUnifiedOpen (trying Xen sub-driver 2)
> libvir: Xen Daemon error : internal error failed to connect to xend
> libvir: Xen Daemon error : internal error failed to connect to xend
> DEBUG: xen_unified.c: xenUnifiedOpen (Xen sub-driver 2 open failed
> )
> DEBUG: libvirt.c: do_open (driver 2 Xen returned ERROR)

So XenD driver failed - check

 - That XenD is running
 - That /etc/xen/xend-config.sxp has '(xend-unix-server yes)' set
 - That the XenD process has /var/lib/xend/xend-socket open (use lsof)

Dan.
-- 
|: Red Hat, Engineering, Boston   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]