[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] listen_tls not enabling libvirtd to listen for tls



On Tue, May 13, 2008 at 05:04:43PM +0300, Kenneth Nagin wrote:
> > Kenneth Nagin wrote:
> > > libvirtd is not listening for TLS connection by default.
> > > Setting 'listen_tls = 1' in /etc/libvirt/libvirtd.conf does not help
> > > either.
> > > However, starting 'libvirtd --listen' does work.
> > > I'm running Fedora 8.   I prefer to use the configuration file since
> > > it is automatically started when the system reboots.  Does anyone
> > > know how to configure libvirtd to listen for tls?
> >
> > Yes.  As you found out, there are 2 things you need to do, the first
> > of which is
> > to instruct libvirtd to listen, and the second of which is to make
> > it listen for
> > TLS.  You can accomplish the first on Fedora by editing
> > /etc/sysconfig/libvirtd
> > and uncommenting the LIBVIRTD_ARGS="--listen" line.  You can accomplish
> the
> > second by edit /etc/libvirt/libvirtd.conf by uncommenting the "listen_tls
> = 1"
> > line.  Then "service libvirtd restart", and you should be good to go(this
> will
> > also preserve the configuration across reboots).
> >
> > Chris Lalancette
> Thanks for the quick response.  That solved the problem.  I suggest
> updating the web document on
> remote support.

  Even better, send us a patch with your suggested documentation udate :-)
The web site is a checkout of the libvirt CVS docs subdirectory. Do a 
CVS checkout, edit remote.html.in and send us the diff, it's not hard
and may help others !

  thanks in advance,

Daniel

-- 
Red Hat Virtualization group http://redhat.com/virtualization/
Daniel Veillard      | virtualization library  http://libvirt.org/
veillard redhat com  | libxml GNOME XML XSLT toolkit  http://xmlsoft.org/
http://veillard.com/ | Rpmfind RPM search engine  http://rpmfind.net/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]