[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] virsh create Guest Crashing



On Mon, May 19, 2008 at 12:07:59PM +0300, Kenneth Nagin wrote:
> 
> An image that  comes up successfully is crash when be created with virsh:
[...]
> It crashes shortly after creation.  This is the snapshot of the xen log:
[...]
> [2008-05-19 12:00:56 4937] DEBUG (DevController:150) Waiting for devices
> vtpm.
> [2008-05-19 12:00:56 4937] INFO (XendDomain:1130) Domain ken-30 (59)
> unpaused.
> [2008-05-19 12:01:00 4937] WARNING (XendDomainInfo:1203) Domain has
> crashed: name=ken-30 id=59.
> [2008-05-19 12:01:00 4937] DEBUG (XendDomainInfo:1821)
> XendDomainInfo.destroyDomain(59)
> 
> I've changed the XML configuration many different ways but nothing seems to
> help.  Any suggestions?

  All the devices seems to be successfully started up. There is something
else going on. I suggest to check in /var/log/xen/xend.log for the two
S-Expressions given to xend between the xm launch and the virsh launch.
There must be a difference given which leads to some emulation breakage.
Guessing what a priori is not very efficient, the difference has
to be found in the logs output between both creations.

Daniel

-- 
Red Hat Virtualization group http://redhat.com/virtualization/
Daniel Veillard      | virtualization library  http://libvirt.org/
veillard redhat com  | libxml GNOME XML XSLT toolkit  http://xmlsoft.org/
http://veillard.com/ | Rpmfind RPM search engine  http://rpmfind.net/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]