[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Problems in using Storage APIs in libvirt



Hi,

I have got the problem solved. I could now compile the code using Storage APIs also. But I run them I am getting error message: "libvir: Remote error : unknown procedure: 72"

The API I used is: virConnectListStoragePools

What is the problem here? How could I solve this. My OS is SLES 10 sp2 and hypervisor is XEN.

Thanks,
Amudhan.


>>> Chris Lalancette <clalance redhat com> 05/22/08 12:10 AM >>>
Amudhan Gunasekaran wrote:
> Hi,
> 
> I am getting the following the error when I try to use ANY storage related APIs.
> 
> undefined reference to '<method name>' for example,
> 
> undefined reference to virConnectListStoragePools.
> 
> I checked in the libvirt.h and it has the method definition. I checked the libvirt.c and it has the implementations. I can not figure out why I get this error. I could use APIs related the network, for example virConnectListNetworks. Where could I have gone wrong and what are the work-arounds to solve them?
> 
> I am using SLES 10 SP2.

This probably means that libvirtd and/or virsh is still using the old copy of
the library.  If you have a libvirt package installed, and then you built the
the CVS libvirt by hand, the CVS version probably got installed somewhere to
/usr/local/lib, which is in the search path after where libvirt is probably
installed to /usr/lib.  Try removing your libvirt package and doing a "make
install" in the CVS version; you should then have everything matching up.

Chris Lalancette



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]