[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] add the check whether the domain has already used a disk which attach



On Thu, Nov 06, 2008 at 07:15:07PM +0900, S.Sakamoto wrote:
> > On Wed, Nov 05, 2008 at 10:05:14AM +0900, S.Sakamoto wrote:
> > > Hi,
> > > 
> > > "attach-disk" does not give an error,
> > > when the domain which is attached has already used the source which attach.
> > > This has danger of the data corruption.
> > > 
> > > I make the patch to add the check of this.
> > > This patch outputs an error,
> > > when the domain which is attached has already used the source which attach.
> > 
> > What hypervisor were you testing with ?  AFAIR, XenD should already raise
> > an appropriate error in this scenario.
> > 
> XenD Don't check this
> when I confirm it in xen(cs 18756:5fd51e1e9c79).
> 
> Therefore,
> I think that it had better add check to virsh.c,
> because this should be checked whether xen or qemu.

No, because then the check is only performed for people using virsh, and
would have to be duplicated across every single other application using
libvirt. If it is done in the XenD or libvirtd at time of use, then all
users of libvirt are automatically protected.

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]