[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] --with-xen=foo



On Thu, Nov 20, 2008 at 10:46:25AM -0500, Ben Guthro wrote:
> I did a git bisect, and as predicted, the culprit seems to be
> 
> aac3e1ab15645f1ff491b140ddb249b01397bebd is first bad commit
> commit aac3e1ab15645f1ff491b140ddb249b01397bebd             
> Author: Daniel P. Berrange <berrange redhat com>            
> Date:   Mon Nov 17 10:43:30 2008 +0000                      
> 
>     Build drivers as libtool convenience libs
> 
> 
> Once again, I am faced with my ignorance of how automake 
> magic works.
> 
> It looks to me like XEN_CFLAGS is set properly...but clearly 
> they are not being passed on while compiling stats_linux.c

Argggh. I didn't notice that stats_linux.c had Xen specific
code in it :-(  When I did the refactoring, it changed so
that XEN_CFLAGS/LDFLAGS is only used for the Xen driver code

As a quick workaround, edit the line for

  libvirt_la_CFLAGS = $(COVERAGE_CFLAGS) -DIN_LIBVIRT

to add  $(XEN_CFLAGS)


Meanwhile I'll figure out  why stats_linux.c needs Xen, and move the Xen
specific bit into the Xen driver.

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]