[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Xen Migration does not work



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Stefan de Konink schreef:
> I'm try to migrate using libvirt:
> 
> virsh # migrate 0802367323_PIQ002 xen://xen002.local/
> libvir: Xen Daemon error : POST operation failed: xend_post: error from
> xen daemon: (xend.err 'Missing parameter: node')
> 
> virsh -v
> 0.4.6

Xen 3.3

    def domain_migrate(self, domid, dst, live=False, port=0, node=-1,
ssl=None):
        """Start domain migration.

        @param domid: Domain ID or Name
        @type domid: int or string.
        @param dst: Destination IP address
        @type dst: string
        @keyword live: Live migration
        @type live: bool
        @keyword port: relocation port on destination
        @type port: int
        @keyword node: use node number for target
        @type node: int
        @keyword ssl: use ssl connection
        @type ssl: bool
        @rtype: None
        @raise XendError: Failed to migrate
        @raise XendInvalidDomain: Domain is not valid
        """


And I don't have a clue what 'node' means in this respect.


Stefan
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEAREKAAYFAkjqC4AACgkQYH1+F2Rqwn3XKwCeJSoYXQN2HdfFMvgbdUNb+zxF
+WMAnRyHy8rknbfgUsnx/9M7J+3VM5uz
=CvM/
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]