[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirt - Configure fails with error message



On Fri, Oct 10, 2008 at 02:58:55PM +0200, Ricardo Tiago wrote:
> Hi,
> 
> When i try to run configure it fails asking me to install the gnutls
> library, which is already installed.
> 
> Output from configure:
> 
> checking for struct _xmlURI.query_raw... no
> checking gnutls/gnutls.h usability... yes
> checking gnutls/gnutls.h presence... yes
> checking for gnutls/gnutls.h... yes
> checking for gnutls_handshake in -lgnutls... no
> configure: error: You must install the GnuTLS library in order to
> compile and run libvirt
> 
> [user1 xxx libvirt-0.4.6]# rpm -qa | grep gnutls
> gnutls-devel-1.4.1-3.el5_1
> gnutls-1.4.1-3.el5_1
> 
> After some checking in configure.in I verified that what was really
> missing is libgcrypt-devel.

This is a packaging bug - since gnutls depends on gcrypt, the
gnutls-devel package should have Requires: libgcrypt-devel.

> I believe the error message should be updated and provide more details
> or at least a check for libgcrypt should be done before the gnutls
> check.

Well libvirt is not using libgcrypt - we're using gnutls. If gnutls 
happens to use libgcrypt internally then it should require it. We 
shouldn't have to second guess what dependant libraries gnutls is
requiring

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]