[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/2] adapt to API change in gnulib



On Thu, Oct 23, 2008 at 12:12:45PM +0200, Jim Meyering wrote:
> This is actually two changes sets.
> The first part is an update from gnulib (including the fix for API change),
> the second adjusts .cvsignore files (sorting at same time)
> so that "git status" is clean after you run "make sync-vcs-ignore-files"
> to generate all .gitignore files.
> 
> For reference, the complete (5000+-line) patch is here:
> 
>     http://meyering.net/code/tmp/libvirt-gnulib.patch
> 
> If no one comments, I'll commit this in a couple hours.

Can you verify that libvirt still builds under MinGW with this
update. There has been a recent addition to gnulib for winsock
wrappers, and this meant we had to update various things in
GTK-VNC code when applying - I have a feeling we'll hit similar
problems with libvirt remote driver + mingw with this gnulib 
update. We had to remove a bunch of our hand-crafted mingw
compat code sinceit conflicted with stuff gnulib introduced

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]