[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Re: [PATCH 1/6] host ("node") device enumeration - public API additions



I'm not crazy about "node driver" either (it has drifted somewhat from
its original intention, as I understood that many of the "node"
operations may be hypervisor-dependent).

Ben Guthro suggested "Device Monitor" which seems just right to me.   I
*think* it's clear that we're monitoring the node's devices (and not
virtual ones).

Dave


On Tue, 2008-10-28 at 14:01 +0100, Daniel Veillard wrote:
> On Tue, Oct 21, 2008 at 01:49:19PM -0400, David Lively wrote:
> > This patch contains the public API additions.
> > 
> 
>   the libvirt.h part looks just fine at this point for me.
> I'm just wondering a bit about some of the naming "node driver"
> are devkit and Hal really "node drivers", then sound more like
> "device watcher".
>   Maybe the error file should state
>     VIR_FROM_DEVWATCH instead of VIR_FROM_NODE
> then the names we pick for the internal symbols can be changed
> 
>   We will need to augment the terminology section at some point
> but I'm not sure what's the best way to describe those new internal
> APIs, "Node driver" doesn't really fit IMHO, "Device watcher" is a bit
> better but doesn't feel great either.
> 
> 
> Daniel
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]