[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] ld: unknown option: --version-script



On Mon, Sep 08, 2008 at 08:29:30AM -0700, Yushu Yao wrote:
> Hi All,
> 
>     A question when porting to Mac.
> 
> It says:
> 
>         ld: unknown option: --version-script=./libvirt_sym.version
>         collect2: ld returned 1 exit status
>         make[2]: *** [libvirt.la] Error 1
> 
> 
> Indeed --version-script doesn't exist in mac's ld. Can I change it to
> something else with them same functionality? How should I do it?

  I don't know how to do this, I never touched a Mac (well I did once
but it sponteaneously rebooted, I assume I'm not compatible).
  The goal of --version-script=./libvirt_sym.version is to restrict
the set of exported symbols available in the library to just the list
in libvirt_sym.version and not include all public symbols from the
C modules which is the default behaviour. Just find a way to limit
the set of public symbols, that has to be possible in some ways.

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]