[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Fix segfault if no qemu emulator passed



On Tue, Sep 09, 2008 at 09:56:47AM +0100, Daniel P. Berrange wrote:
> On Mon, Sep 08, 2008 at 11:10:17PM -0400, Cole Robinson wrote:
> > There is unfortunately a pretty prevalent
> > segfault in the latest libvirt. If a qemu
> > domain is defined without an emulator
> > specified, libvirtd crashes.
> > 
> > This is doubly unfortunate since current
> > virtinst generates an emulator-less config
> > for all qemu and kvm guests (I'm about to fix
> > this upstream though).
> 
> #%(*&#@(%   Damn. This is worthy of a brown paper bag release for libvirt
> to fix this shockingly bad bug.

  I would not rush, let's isolate the few fixes needed and repush a whole
release in a week or two. There have been so many changes to 0.4.5 that
this kind of things is likely to happen ... more than once.
  Like 0.4.4 was a good release, fixing the obviour errors found in
0.4.3 first 10 days it's a clasical pattern :-)
  Distros with fast update cycles will push the patches, others should
monitor and look for 0.4.6 within 1-2 weeks.
  I will push the patch to Fedoras build,

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]