[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Re: [Qemu-devel] Changing the QEMU svn VERSION string



On 04/07/09 19:13, Jamie Lokier wrote:
Anthony Liguori wrote:
I still think libvirt should work with versions of QEMU/KVM built from
svn/git though.  I think the only way to do that is for libvirt to relax
their version checks to accommodate suffixes in the form
major.minor.stable-foo.

Ok, but try to stick to a well-defined rule about what suffix means
"later" or "earlier".  In package managers, "1.2.3-rc1" is typically
seen as a later version than "1.2.3" purely due to syntax.

Fedora typically handles this using a leading zero in the 'release' component for pre-final versions, like this: app-1.2.3-0.rc1.fc11 (rc/beta) and app-1.2.3-1.fc11 (final). Likewise for snapshots: app-1.2.3-0.svn${date}.fc11

If you're
consistently meaning "0.11.0-rc1" is earlier than "0.11.0" (final),
that might need to be encoded in libvirt and other wrappers, if they
have any fine-grained version sensistivity such as command line
changes or bug workarounds.

libvirt scans the help text to figure which features are present (checking for as -drive and -uuid cmd line switches for example).

cheers,
  Gerd


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]