[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Re: [Qemu-devel] Changing the QEMU svn VERSION string



Anthony Liguori wrote:
> I still think libvirt should work with versions of QEMU/KVM built from 
> svn/git though.  I think the only way to do that is for libvirt to relax 
> their version checks to accommodate suffixes in the form 
> major.minor.stable-foo.

Ok, but try to stick to a well-defined rule about what suffix means
"later" or "earlier".  In package managers, "1.2.3-rc1" is typically
seen as a later version than "1.2.3" purely due to syntax.  If you're
consistently meaning "0.11.0-rc1" is earlier than "0.11.0" (final),
that might need to be encoded in libvirt and other wrappers, if they
have any fine-grained version sensistivity such as command line
changes or bug workarounds.

The Linux kernel was guilty of mixing up later and earlier version
suffixes like this.  With Linux this is a bit more important because
it changes a lot between versions, so some apps do need fine-grained
version checks to workaround bugs or avoid buggy features.  Maybe that
won't even happen with QEMU and libvirt working together.

-- Jamie


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]