[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Multpile network interfaces have same MAC address

On Wed, 25 Feb 2009, Daniel P. Berrange wrote:

On Tue, Feb 24, 2009 at 01:29:41PM -0800, David Mueller wrote:
I remember seeing this problem before, but I can't remember what the
resolution was, nor can I find a discussion of the issue in
the list archives or Bugzilla.

I've had my setup working for a while now, on both Fedora 8 and Fedora 10.
Now I'm trying to get it to work with CentOS 5 and
running into an old bug.  My guest VM has multiple virtual network
interfaces, with the MAC address defined in the XML file used to
define the VM.  However, I'm seeing each network interface getting the
same MAC addrss (the last one defined in the XML file) on
all if the interfaces when I run ifconfig in the guest.

Was there a workaround for this, or do I need to upgrade libvirt?  CentOS
5.2 is what I'm working with; they haven't released 5.3
yet so I don't know if that will have a newer version.

Last time I saw this was with QEMU and the rtl8139 nic, where there was
a bug setting up the MMIO space, so all NICs were reading their mac
from the first NIC's region instead of their own.

Does anyone know if the patch for this is going to be rolled into RHEL5 at some point? I'm still having this problem with CentOS 5.3. For reference, I found the original Fedora 7 bug as well as filed one for CentOS:





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]