[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] compiling one driver



Hello,

I'm having problems to compile libvirt with opennebula driver.

I executed: ./autogen.sh --with-one
and got the following message:
configure: error: You must install XMLRPC-C >= 1.14.0 to compile libvirt ONE driver

but I already have installed libxmlrpc version 1.16.07-1

Where to configure this? I've tried to set the environment variables XMLRPC_CFLAGS and XMLRPC_LIBS, but nothing has changed.

So I've tried to change these variables directly on configure script, that was empty, then errors started to appear on make execution:
../src/.libs/libvirt_driver_one.a(libvirt_driver_one_la-one_client.o): In function `c_oneFree':
/home/objectweb/git/libvirt/src/./opennebula/one_client.c:207: undefined reference to `xmlrpc_env_clean'
/home/objectweb/git/libvirt/src/./opennebula/one_client.c:208: undefined reference to `xmlrpc_client_cleanup'
../src/.libs/libvirt_driver_one.a(libvirt_driver_one_la-one_client.o): In function `c_oneReturnCode':
/home/objectweb/git/libvirt/src/./opennebula/one_client.c:49: undefined reference to `xmlrpc_decompose_value'

.....etc...

What am I doing wrong??

Thanks,

Henrique Teófilo


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]