[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] Re-name remote_internal.c:driver to remote_driver



Confused me when poking at another 'driver' variable in gdb which gcc
had optimized away

* src/remote_internal.c: rename driver to remote_driver
---
 src/remote_internal.c |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/remote_internal.c b/src/remote_internal.c
index a58b768..de3c288 100644
--- a/src/remote_internal.c
+++ b/src/remote_internal.c
@@ -7461,7 +7461,7 @@ unsigned long remoteVersion(void)
     return REMOTE_PROTOCOL_VERSION;
 }
 
-static virDriver driver = {
+static virDriver remote_driver = {
     VIR_DRV_REMOTE,
     "remote",
     remoteOpen, /* open */
@@ -7639,7 +7639,7 @@ static virStateDriver state_driver = {
 int
 remoteRegister (void)
 {
-    if (virRegisterDriver (&driver) == -1) return -1;
+    if (virRegisterDriver (&remote_driver) == -1) return -1;
     if (virRegisterNetworkDriver (&network_driver) == -1) return -1;
     if (virRegisterInterfaceDriver (&interface_driver) == -1) return -1;
     if (virRegisterStorageDriver (&storage_driver) == -1) return -1;
-- 
1.6.2.5


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]