[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 2/2] RPM spec file updated with glusterfs dependency



Hi Gerrit,

      Problem i can see here is the CentOS, RHEL and Scientific Linux never really built a package for 2.x releases of glusterfs and 1.3.x is really almost 2yr+ old.
Having a dependency moved to 1.3.8 will actually break everything which glusterfs provides. 2.x are incompatible with 1.3.x releases, i would suggest a package upgrade bugzilla ticket against the CentOS/RHEL maintainers for glusterfs packages. Fact is 1.3.x has been not supported by us since long time now as there
were no new developments in that branch.

Regards
--
Harshavardhana
Gluster - http://www.gluster.com


On Sat, Aug 29, 2009 at 3:50 AM, Gerrit Slomma <roadrunner_gs web de> wrote:
On Tue, Jul 07, 2009 at 05:47:56AM -0700, Harshavardhana wrote:
> Add new dependency for glusterfs rpm.
[...]
> +# For glusterfs > +Requires: glusterfs-client >= 2.0.2
>  %endif

 why 2.0.2 ? is taht a hard requirement ? In Fedora/Rawhide we have
only 2.0.1 at the moment,

Daniel

--
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/
Tested libvirt-0.7.0 today.
And this requirement really breaks installation of builds on RHEL/CentOS/ScientificLinux.
The newest available built for glusterfs is those systems is glusterfs-client-1.3.8 from freshrpms.
Even --without-storage-fs does not help a bit, must be pulled in implicitly?

rpm -pq --requires libvirt-0.7.0-1.x86_64.rpm
(...)
glusterfs-client >= 2.0.1
(...)

Is this patched in upcoming 0.7.1 or how could i go around this issue?


--
Libvir-list mailing list
Libvir-list redhat com
https://www.redhat.com/mailman/listinfo/libvir-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]