[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Segmentation fault when shutting down VMs



2009/12/10 Thomas Treutner <thomas scripty at>:
> On Friday 13 November 2009 12:46:24 Daniel P. Berrange wrote:
>> On Fri, Nov 13, 2009 at 11:42:46AM +0100, Thomas Treutner wrote:
>> > Hi,
>> >
>> > I'm facing another problem with latest git.
>> >
>> > This happens regularly when shutting down VM(s):
>> >
>> > http://pastebin.com/m4ef1d93f
>> >
>> > It doesn't depend on which or how many VM is/are shut down, or if I have
>> > a VNC connection to a VM that is shutting down. Sometimes after a segv, I
>> > get this:
>> >
>> > http://pastebin.com/m5260bf21
>> >
>> > It seems to me that libvirt tries to query a qemu monitor that is no
>> > longer alive?
>>
>> This second problem is fixed by
>>
>> http://www.redhat.com/archives/libvir-list/2009-November/msg00458.html
>>
>>
>> I'm still trying to figure out what's going on with the first problem
>
> I found some time to pull latest git, build, and test a little bit today, and
> it seems to me that the problem has vanished away!
>
>
> -t
>

The problem has been fixed by the combination of this two commits:

http://libvirt.org/git/?p=libvirt.git;a=commit;h=79533da1b36cc16e0f3f8aea798d6cc20528c451
http://libvirt.org/git/?p=libvirt.git;a=commit;h=8e7d14953ca6ef047112bc6ac177507ea8f824f2

Matthias


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]