[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Two issues regarding TFTP support in virtual networks...



The first is just a wiki fix: the wiki says this functionality is
available as of 0.7.1 of libvirt. The code though is only in the 0.7.2
tag and later. So the wiki should say 0.7.2 instead.

The second regards how I'm using it and what I'm doing wrong. I'm
creating a virtual network and pointing it to a temporary directory
where I've run livecd-iso-to-pxeboot to setup an ISO file for PXE
booting. So the network XML looks like this:

(mcpierce mcpierce-desktop:node-image)$ sudo virsh net-dumpxml testbr541
<network>
  <name>testbr541</name>
  <uuid>f389317f-8420-7516-df9d-756b7deb3d37</uuid>
  <forward mode='nat'/>
  <bridge name='testbr541' stp='on' delay='0' />
  <ip address='192.168.31.1' netmask='255.255.255.0'>
    <tftp root='/tmp/tmp.3B8opJfBXw/tftpboot/' />
    <dhcp>
      <range start='192.168.31.100' end='192.168.31.199' />
    </dhcp>
  </ip>
</network>

When I start up the VM, I see it get an IP address within the range
specified, but it never pxeboots the ISO image.

To what directory should the root attribute be pointed?

-- 
Darryl L. Pierce, Sr. Software Engineer @ Red Hat, Inc.
Delivering value year after year.
Red Hat ranks #1 in value among software vendors.
http://www.redhat.com/promo/vendor/

Attachment: pgpM0moHWv7KM.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]