[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Compilation Errors



Russell <russellhaering gmail com> wrote:
> I'm trying to compile libvirt 0.6.0 on Gentoo, but keep encountering
> the following error:
>
> network_driver.c:72: error: expected specifier-qualifier-list before 'brControl'
...
> make: *** [all] Error 2
>
> Every error following the first one refers to networkConfigDir,
> networkAutostartDir, or logDir, all listed after brControl in the
> definition of network_driver.
>
> What looks to me like the same error has been reported against 0.5.1
> here (I haven't tried it myself):
> http://bugs.gentoo.org/show_bug.cgi?id=254568
>
> My configuration options:
> ./configure --prefix=/usr --host=i686-pc-linux-gnu
> --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share
> --sysconfdir=/etc --localstatedir=/var/lib --with-avahi
> --without-storage-iscsi --without-storage-lvm --without-lxc --with-hal
> --without-openvz --without-storage-disk --without-sasl
> --without-selinux --without-uml --without-xen --without-qemu
> --without-devkit --without-polkit --with-remote
> --disable-iptables-lokkit --localstatedir=/var
> --with-remote-pid-file=/var/run/libvirtd.pid --build=i686-pc-linux-gnu
>
> If other info would help resolve this I'd be happy to try and provide it.

You're compiling with neither LXC nor QEMU, and that turns off WITH_BRIDGE,
yet parts of network_driver.c assume bridge-related functions are defined.

If really you want neither LXC nor QEMU, then maybe you also want
--without-network?

I've confirmed that when configured with that additional option
it does build.

If being able to build --without-lxc --without-qemu --with-network
is important, (even if just to forestall bug reports like this one ;-)
then we'll make it work.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]