[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] "type 'hvm' & arch 'i686' combination is not supported" error



On Wed, Feb 25, 2009 at 12:39:30PM +0000, Daniel P. Berrange wrote:
> > <capabilities>
> > 
> >   <host>
> >     <cpu>
> >       <arch>x86_64</arch>
> >     </cpu>
> >   </host>
> > 
> >   <guest>
> >     <os_type>hvm</os_type>
> >     <arch name='x86_64'>
> >       <wordsize>64</wordsize>
> >       <emulator>/usr/bin/qemu-system-x86_64</emulator>
> >       <machine>pc</machine>
> >       <machine>isapc</machine>
> >       <domain type='kvm'>
> >         <emulator>/usr/bin/qemu-kvm</emulator>
> >       </domain>
> >     </arch>
> >     <features>
> >       <acpi default='on' toggle='yes'/>
> >       <apic default='on' toggle='no'/>
> >     </features>
> >   </guest>
> > 
> > </capabilities>
> 
> This shows you haven't got the 32-bit emulator /usr/bin/qemu installed
> which is why its not recognising the i686 arch as valid.

In the past, I have always had KVM installed and not qemu, and this 
sufficed to configure i686 hosts with virt-manager and run them.
So now it seems I need to change either i686 to x86_64 in the
configuration files, either I need to have plain qemu installed. Why is
this needed now?

-- 
Frederik Himpe


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]