[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Question, new libvirt driver - OpenNebula.



On Fri, Jan 09, 2009 at 05:33:56PM +0100, "Abel M?guez Rodr?guez" wrote:
>     We have updated the libvirt implementation
> for OpenNebula to libvirt- 0.5.1  release, made use of the internal XML
> handling  API and the existing infrastructure for error, data
> structures, etc... 
> 
>     Now we are facing the problem of needing
> several libraries to compile the driver,  the OpenNebula API 
> (liboneapi) and the xmlrpc library that the API makes use of. 
> 
>  The problem is that the xmlrpc library itself depends on: 
> libxmlrpc_client++  libxmlrpc_client libxmlrpc++ libxmlrpc 
>  libxmlrpc_util   libxmlrpc_xmlparse libxmlrpc_xmltok  
> 
> We would like to link just against less libraries to make 
> the driver compilation clear and simple, any idea?

Well if those are the deps of liboneapi library there's no much we can
do about that - just have to link to them. Just make sure they are all
LGPL (or GPLv2+) compatible. We now have ability to build drivers as
dlopen'd modules, so it would neccessarily impact the set of linker
deps of the main libvirt.so library.


Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]