[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] bug: libvirt hang while restore a domain



Hi,

i try to restore a domain without a valid disk (I deleted the diskfile
before restoring it ...). Normally, this must always produce an error.


** The first time,  an error occurred - OK:
[root xen03 srv]# virsh restore /srv/save 
libvir: QEMU error : operation failed: failed to start VM
error: Failed to restore domain from /srv/save

** But the second time, the command hang:
[root xen03 srv]# virsh restore /srv/save 

^C
[root xen03 srv]# virsh  list
^C
[root xen03 srv]#

I can't use libvirt now, until restarting the daemon....

*** The domain looks like this (/tmp/winxp100 does NOT exist)
<domain type='kvm' id='3'>
  <name>winxp100</name>
  <uuid>4e991a91-5db6-0584-3750-6a288ae01ee4</uuid>
  <memory>256000</memory>
  <currentMemory>256000</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='i686' machine='pc'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/kvm/bin/qemu-system-x86_64</emulator>
    <disk type='block' device='disk'>
      <driver name='qemu'/>
      <source dev='/tmp/winxp100'/>
      <target dev='hda' bus='ide'/>
    </disk>
    <interface type='bridge'>
      <mac address='52:54:00:cf:3e:66'/>
      <source bridge='br0'/>
      <script path='/etc/kvm/kvm-qemu-ipup.sh'/>
      <target dev='vnet1'/>
      <model type='e1000'/>
    </interface>
    <serial type='pty'>
      <source path='/dev/pts/6'/>
      <target port='0'/>
    </serial>
    <console type='pty' tty='/dev/pts/6'>
      <source path='/dev/pts/6'/>
      <target port='0'/>
    </console>
    <input type='tablet' bus='usb'/>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5901' autoport='yes'/>
  </devices>
</domain>

Is this a bug ?

regards
Danny


-------------------------------------------------------------------
DT Netsolution GmbH   -   Taläckerstr. 30    -    D-70437 Stuttgart
Geschäftsführer: Daniel Schwager, Stefan Hörz - HRB Stuttgart 19870
Tel: +49-711-849910-32, Fax: -932 - Mailto:daniel schwager dtnet de




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]